TabPy: how to install pre-release package

What and Why?

Before showing steps you can upgrade you TabPy to the latest pre-release version some terminology needs to be explained (all the explanations are generalized and are not exact):

  • TabPy release – a packaged snapshot of TabPy sources and artifacts with a tag (version) attached to it. You don’t need to use any of the releases in any way unless you are a contributor to TabPy. Releases are created when some feature, improvement or significant bug fix is added to the codebase. All releases can be seen at https://github.com/tableau/TabPy/releases.
  • Pre-release – specific version for which all quality confirmation hasn’t been done yet. You can see some releases are marked as Pre-release and some other as Verified.
  • TabPy package – TabPy release (not exactly, but very close to it) published on pypi.org. All the packages from the site can be installed on user environment with pip install <package_name> command.
  • TabPy pre-release packaged is published on test.pypi.org instead but is technically the same package which later when promoted to Verified release is published on pypi.org.

Why would you want or need to install or upgrade your TabPy to pre-release package? The only two reasons are:

  • There is a feature you need, or
  • There is a bug fix you need.

However, some warning has to be made:

  • Pre-release packages are not tested to the full and only meant to be used to unblock a scenario with a new feature or a bug fix.
  • Pre-release packages won’t necessarily be approved ever and can be recalled.
  • Pre-release packages may contain breaking and incompatible changes.
  • Upgrading from a pre-release package to a release may not be possible.
  • There may not be any bug fixes, improvement or investigations on pre-release packages.

How?

Actually installing or upgrading to a pre-release package is as simple as specifying repository with pip command parameter. For test.pypi.org the parameter is -i https://test.pypi.org/simple/. And the whole command to install the latest pre-release package is

pip install --upgrade -i https://test.pypi.org/simple/ tabpy

And you can specify the exact version of a package, e.g.

pip install --upgrade -i https://test.pypi.org/simple/ tabpy==0.8.13

What’s Next?

If the pre-release version works for you – keep using it until you need to upgrade for the newer version. You can upgrade (or rather try to upgrade – see the warnings above) to a newer pre-release package as shown in the previous section. Or you can even upgrade to the newer “official” package with the regular pip install --upgrade tabpy command.

In case when the upgrade is not possible for any reason you’ll need to uninstall your current TabPy with pip uninstall tabpy command and simply install it again.

0 0 vote
Article Rating
Share the post if you liked it
  •  
  •  
  • 2
  •  
  •  
  •  
    2
    Shares
Oleksandr Golovatyi

Author: Oleksandr Golovatyi

Member of Tableau Advanced Analytics team and a contributor to TabPy and this blog.

Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments